EGEsoll - сборник решений задач из ЕГЭ

Задача 4 работа с предыдущим

Исполнитель А22 преобразует целое число, записанное на экране.

У исполнителя три команды, каждой команде присвоен номер.

1. Прибавь 1.

2. Прибавь 3.

3. Прибавь предыдущее.

Первая команда увеличивает число на экране на 1, вторая увеличивает это число на 3, третья прибавляет к числу на экране число, меньшее на 1 (к числу 3 прибавляется 2, к числу 11 прибавляется 10 и так далее). Программа для исполнителя А22 — это последовательность команд.

Сколько существует программ, которые число 2 преобразуют в число 10?

Добавлено: 10.04.26 19:30

Перейти к решению

Решение

Ответ: 39

Решение на Python:

def f(s, e):
    if s > e:
        return 0
    if s == e:
        return 1
    return f(s + 1, e) + f(s + 3, e) + f(2 * s - 1, e)

print(f(2, 10)) # 39

Автор - rubygem17

Объяснение

None

Назад